Chevy Tri Five Forum banner
ignition
1-5 of 5 Results
  1. Electrical Questions and Answers
    I havent touched my points for about 17,000 miles (I know, looong overdue!) And ive decided to switch to either the pertronix 2 or 3 system and accompanying coils. Besides a roller cam, my engine is just a regular old 57 283 powerpack. With my 2004r i never go much over 3000 rpm in any...
  2. Electrical Questions and Answers
    Hey guys, so im at the end of my rope with this one. So my main issue is that my 56 Nomad with a 327 was not getting spark. I knew this because I tested a few plugs and the lead plug with a spark tester. I've recently changed the coil to a Blaster 2 and added a magnetic distributor, rebuilt my...
  3. Electrical Questions and Answers
    Hello and thanks for any help in advance, this is my first post on trifive. I have a 57 Chevy Bel Air after his passing. So still trying to learn about this car. I know that it has a small block 406 with MSD ignition. My mother took the battery up backwards in the car last year. And I've been...
  4. Trifive Trucks Suburbans & Panel vans
    I purchased a 57 3200 LWB a couple of weeks ago. An ignition wire fell off the fuse box (I think). Now truck won't start and I don't know where to plug it back in. I tried one spot on the panel and got a brief vroom, then stall, now nothing again. Hope I didn't fry something that fast. Any ideas?
  5. Electrical Questions and Answers
    Hi Folks, I turned off my 57 Bel Air - running smoothly - and tried to start it again about 30 minutes later. Heard a click but the starter did not engage. All dash lights work. Battery shows full charge. Both battery cables are tight at both ends. Any ideas? Thanks in advance. Rob
1-5 of 5 Results
Top