Chevy Tri Five Forum banner
starting
1-5 of 5 Results
  1. Electrical Questions and Answers
    Hello all- New member to the forums, just got my first classic car as a project and already having some questions. I'm pretty new with this stuff as a new hobby, so forgive my ignorance. My '57 Bel Air is having intermittent starting issues and I suspect a bad ground. "GEN" light comes on in...
  2. Electrical Questions and Answers
    For all you experts out there, I am having an issue where as long as I keep the key engaged with the starter, the car starts and engine runs fine. As soon as I release the key to "run" position, it cuts off. Thoughts? Battery is new and good. Starter is new and good. New plugs and wires...
  3. Electrical Questions and Answers
    Does anyone have a real simple wire diagram to get the engine started? From the ignition key to the starter, the the distributor to the plugs to battery to ground....I'm just trying to get the engine started and just a breakdown of the wires it'll take to get the beast started. I have a 55 210...
  4. Electrical Questions and Answers
    I relearned a lesson today with my 55 that I first learned 10 years ago on my 57. Either I'm smart for remembering or completely stupid for letting it happen again. Here's the lesson: Poor grounds cause resistance to increase and prevents proper amperage from flowing to high-demand systems...
  5. Stock Chevy Discussion 55-56-57
    Hey there, I just recently got my '56 Bel Air 4 dr sedan back from getting the stock 265 engine fully rebuilt. Runs great, and it looks like I'm getting about 25 mpg cruising! (13mp with heavy acceleration from starts). However, as the title says, it's now not starting. The situation right...
1-5 of 5 Results
Top