Chevy Tri Five Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter · #1 ·
I am polishing my hubcaps.i think im done,then i notice the ring that has the chevy emblems has a milky white covering.the emblems are silver.but i see a chrome color in spots.i remove the whitish color and its all chrome now.also the embkems are a brass color ! Ive only done one.did i screw up ?
 

·
Stainless Trim Restoration
Joined
·
12,463 Posts
I am polishing my hubcaps.i think im done,then i notice the ring that has the chevy emblems has a milky white covering.the emblems are silver.but i see a chrome color in spots.i remove the whitish color and its all chrome now.also the embkems are a brass color ! Ive only done one.did i screw up ?
The 150 and 210 small caps were all brass and flash chrome plated. The insert was painted winter white.

The same color the belair side trim insert was painted. Also the same on the lower paint dividers. This is spec but the color varied from this over the production run, and some pcs look almost white. But not because the color spec changed.

Mikey
55wagoncrazy
 

·
Registered
Joined
·
157 Posts
Discussion Starter · #6 ·
hub color

Ok ty for the info guys.the brass color was a mystery.for now i will leave one side of the car with the milky ring and the other all chrome.the white ring has aged and is about 90% white with 10% chrome showing.
 

·
Premium Member
Joined
·
5,139 Posts
... then i notice the ring that has the chevy emblems has a milky white covering ...
White? Milky? Sure you weren't just polishing a bit too hard?
 

·
Registered
Joined
·
1,127 Posts
I picked up a new set at a swap meet earlier this year. They weren't terribly expensive, think I paid $130 for the set. The white was already painted and nothin like new chrome!
 

Attachments

1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top