Chevy Tri Five Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Glad to be a member of this group! I have owned my Chevy for 12 years and all of a sudden, when I put it in 3rd gear my clutch pedal jammed in the upper (engaged) position!! Luckily I was able to force it into neutral to stop the car and then get it home. Obviously the clutch pedal shaft is interfering with the 2nd/3rd lever. Any help would be appreciated. Thank you.
 

·
Trifive Automotive Electrical Wiring Expert
Joined
·
25,989 Posts
Glad to be a member of this group! I have owned my Chevy for 12 years and all of a sudden, when I put it in 3rd gear my clutch pedal jammed in the upper (engaged) position!! Luckily I was able to force it into neutral to stop the car and then get it home. Obviously the clutch pedal shaft is interfering with the 2nd/3rd lever. Any help would be appreciated. Thank you.
The rear rubber engine mounts may be broken. https://www.trifive.com/garage/55%20Chevy%20Assembly%20Manual/6-8-01.gif
 

·
Trifive Automotive Electrical Wiring Expert
Joined
·
25,989 Posts
I could have sworn this was the 55-57 Corvette section. Did I miss something?
I guess I assumed it was a passenger car, since I didn't look to see which section it was in and Corvettes don't have manual columns.
 

·
Administrator & Tech Articles
Joined
·
49,428 Posts
I wondered if it was actually a corvette or a passenger car he was talking about.....Terry
I sent the originator of this thread a PM asking, but have not heard back yet.
 

·
Trifive Automotive Electrical Wiring Expert
Joined
·
25,989 Posts
His profile says his favorite car is a 1955 Belair.
 

·
Administrator & Tech Articles
Joined
·
49,428 Posts
1 - 8 of 8 Posts
Top