Chevy Tri Five Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
3,338 Posts
That doesn't look like fun, had a fan blade break off once and go through the hose and hood like that but I didn't get anywhere near that much damage...
 

·
Registered
Joined
·
1,199 Posts
I asked my wife the same thing, she told me to roll over and go back to bed....

Sorry to hear hear that bud. Hopefully it's a fairly quick turnaround.
 

·
Registered
Joined
·
1,342 Posts
Wow!!!! Looks like the damage from a shotgun slug and samurai sword! Hope everyone is ok? This may be the time to upgrade to the aftermarket parts you want. The damage doesn't look to substantial. You should recover soon. Good luck.

Tom
 

·
Administrator
Joined
·
9,085 Posts
I know this is off topic, but those alternator mounts are they made or can you buy them, they look very strong.

Otis
 

·
Registered
Joined
·
258 Posts
Discussion Starter · #13 ·
I know this is off topic, but those alternator mounts are they made or can you buy them, they look very strong.

Otis
the altenator bracket is alan grove. not to terribly expensive. the serpentine setup is of an 85 pontiac parisenne with a 305.

http://www.alangrovecomponents.com/

going to upgrade to an electric pump and fans. looking at an aluminum radiator and maybe aluminum core support. thanks for support guys its like a kick to the nuts when something like this happens.
 

·
Administrator
1957 Bel Air sport sedan
Joined
·
9,074 Posts
good googilie moogilie!!! Hopefully it won't take too much moolah or time to get it back on the road! Glad everyone is ok though!
Eldon
 

·
Registered
Joined
·
1,465 Posts
I had two blades on a viscous fan bend (?) driving to work and they then cut a ring out of my rad like that!! £275 ($425) for a recore! Put a Mr Gastet lekky fan on after that!
 

·
Registered
Joined
·
6,404 Posts
I see threads like this one and all I can think is that I should hire a tow truck to follow me around when I take my 57 out for it's first trip!
 

·
Registered
Joined
·
1,465 Posts
I see threads like this one and all I can think is that I should hire a tow truck to follow me around when I take my 57 out for it's first trip!
I'd been driving mine for nearly a year when that happened. I have no idea how, but I turned left into the street leading up to the office and klunk, woosh! All steam and no visibility!

My first drive was from the docks! All power (300 bhp) and original drums all round!:eek: Now with anti-roll bars F&R and discs with 9" servo, all is good!!:D
 

·
Registered
Joined
·
1,692 Posts
Wow! some serious carnage. Was sitting in my buddys 70 1/2 camaro in the high school parking lot, he decides to impress or scare the girls walking by, fires it up, pins the throttle to the floor,, KABOOM! fan blades thru the hood.
 

·
Registered
Joined
·
10 Posts
Sinking feeling.....

I got that 'sinking' feeling when I saw the photos....
Now that you have dried yourself off....time to get that thing repaired!
Did you show those photos to AutoZone? They SHOULD see them!
 

·
Registered
Joined
·
18 Posts
:eek: Wow! Sorry to see that! I'm sure that was lots of thrills-n-chills!! You may have a hard time taking the wife out crusin for a while. Good luck on the repairs!
 
1 - 20 of 21 Posts
Top