Chevy Tri Five Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
My '57 Chevy has no brake lights. There is power to the fuse and power to brake pedal switch. Does any one know what I should do next to fix this problem?
 

·
Trifive Automotive Electrical Wiring Expert
Joined
·
26,959 Posts
Do the turn signals work? If the rear turn signals work, check the white wire for power, that goes to the turn signal switch from the brake switch at the connector coming out of the steering column.
 

·
Registered
Joined
·
67,344 Posts
:hello: hi tf and welcome. good to have you here. power to the sockets and bulbs.
 

·
Premium Member
Joined
·
1,481 Posts
Have you tried a test light to see if you are getting power at the rear of the car. When I rewired mine I had a problem getting a good ground before I got the rear lights to work.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
brake electrical

Thanks to you guys for giving me some tips. I will check out those tips and report back. What should I do next if no power at rear brake lights?
 

·
Administrator & Tech Articles
Joined
·
51,227 Posts
Check both sides of the brake light switch for power, when the pedal is depressed.....Could be as simple as adjusting or replacing the switch.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 · (Edited)
Brake electrical

Here is an update to my not having any brake lights. I have power to brake pedal switch and power coming out of white and and purple (the 2 that power the brake lights) wires on turn signal switch on both sides of that connector. However the brake and turn signal lights do not work, front or back but do have both rear and parking lights working. I am stumped as to what to look at next. Any suggestions would be appreciated.
 

·
Trifive Automotive Electrical Wiring Expert
Joined
·
26,959 Posts
Here is an update to my not having any brake lights. I have power to brake pedal switch and power coming out of white and and pink?(the 2 that power the brake lights) wire on turn signal switch on both sides of that connector. However the brake and turn signal lights do not work, front or back but do have both rear and parking lights working. I am stumped as to what to look at next. Any suggestions would be appreciated.
The white wire sends power to the turn signal switch. The pink and purple wires send power to the rear brake/turn lights. The dark and light blue wires send power to the front turn signals.
If you have power at the pink wire, check for power on the pink wire at the rear harness connector under the dash near the drivers kick panel. The pink wire goes to the left brake/turn light.
Check for power at the yellow wire in the turn signal connector also. The flasher could be defective, keeping the turn signals from working.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #11 ·
Thanks for the diagram, Don. I didn't see it under the dash when I looked, it must be way up there and I missed it. I'll check it out tomorrow. But even if the flasher unit is bad my brakes still don't work!
 
1 - 11 of 11 Posts
Top