Chevy Tri Five Forum banner
1 - 20 of 32 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
Just got off the phone with Custom autosound and another 160.00 later ,they say I'll get back a radio that will work for more than 6 months.I talked to Mike (the owner ? of Custom Autosound)at the Sema show this year and told him about the problems with his radios,he told me to send it in for repairs and that he would take care of it,it's a USA-5,and he did mention that they had problems with this system.Well after taking apart the dash with the air cond,of course ,I sent it in with a nice long letter explaining everything,so then I get the call and they tell me the circut board is fried,because ,as you might guess, it was installed wrong,and the only way to fix it is with a new circut board and Mike won't stand behind it.Sorry about the length of this,but I just had to vent a little.Don't think I'll be buying any more Custom Autosound products EVER again.Next time it goes out ,I'll just drive a little faster and listen to the sound of the motor,I'd like that better anyway.
 

·
Registered
Joined
·
12,123 Posts
Venting your frustrations is great as it helps others to be aware of what is causing you pain. We always hate to hear of stories like this but it serves as a warning to others. I hope it all gets resolved for you and soon. I realise you will never get back any of the hours you put in with all of this.
 

·
Trifive Facebook Admin
Joined
·
10,611 Posts
Sorry for your problems, but I have yet to hear much good about their systems, other than they look like the originals, seems they work the same way too:rolleyes:

Randy
 

·
Registered
Joined
·
208 Posts
Bought one for my 69 camaro, one side had no sound. Sent it back, same thing.
Tied a dollar around, threw it in the trash so I could say I threw something away.
Wont have another.
 
Joined
·
68,758 Posts
sorry to hear this hotrod, but it might help others. thank you. ............venting is a good thing. :five:
 

·
Registered
Joined
·
164 Posts
I've been looking for a new stereo for my 55, Because all I've read about Custom Autosound, I'm avoiding them like the plague!

I was looking at the bowtie dash trim w/out a radio hole, then installing a good brand out of the way in the glove box.

It's 30 degrees in my garage today so I have some time to think about it...like until spring!:sign0020:
 

·
Registered
Joined
·
7,275 Posts
I put one in my 67 Camaro when my 30 something year old Pioneer Super Tuner died it is junk. I was then stupid enough to buy one of thier resto AM/FMs for my 55, it has been back once already with an 8 week plus turn around.
 

·
Registered
Joined
·
4,760 Posts
Just got off the phone with Custom autosound and another 160.00 later ,they say I'll get back a radio that will work for more than 6 months.I talked to Mike (the owner ? of Custom Autosound)at the Sema show this year and told him about the problems with his radios,he told me to send it in for repairs and that he would take care of it,it's a USA-5,and he did mention that they had problems with this system.Well after taking apart the dash with the air cond,of course ,I sent it in with a nice long letter explaining everything,so then I get the call and they tell me the circut board is fried,because ,as you might guess, it was installed wrong,and the only way to fix it is with a new circut board and Mike won't stand behind it.Sorry about the length of this,but I just had to vent a little.Don't think I'll be buying any more Custom Autosound products EVER again.Next time it goes out ,I'll just drive a little faster and listen to the sound of the motor,I'd like that better anyway.
This is disheartening news as I have a brand new one that my wife bought me last christmas from Ecklers sitting in the basement waiting to be installed. eek!!
 

·
Administrator
Joined
·
68,043 Posts
It clearly goes to show that there are some companies that stand by their products hence the warranty or faulty products when disputed are taken care of without the customer having to be out of pocket.
 

·
Registered
Joined
·
2,858 Posts
This is disheartening news as I have a brand new one that my wife bought me last christmas from Ecklers sitting in the basement waiting to be installed. eek!!
See if they will take it back and refund your money. Dave
 

·
Registered
Joined
·
6,563 Posts
"and he did mention that they had problems with this system."..............
That alone, tells me he should have stepped up and done the right thing.
 

·
Registered
Joined
·
123 Posts
+1 on Custom Autosound being junk. Or is that a -1?

Same story here, about 7 years back in my 65 Thunderbird. The radio lasted maybe 6 months before it died, and Custom Autosound claimed it was due to "improper installation." The only thing improper about the installation was the piece of junk radio. The Pioneer I put in its place got hooked up to the exact same wiring and connectors and was still going strong when I sold the car last year.

For the 57 I left the original AM radio in place and installed a small amplifier in the glovebox. Wired up an iPod adapter that powers the iPod and provides a line out to the amp and put one of those dual voice coil speakers from Eckler's in the dash. Looks stock, sounds great, plus I have 800+ albums worth of music and no commercials! I think in all I spent about $100.

Sometime if I get ambitious I might pull the AM radio and put a stereo audio taper long shaft pot in the volume position, wire it between the iPod adapter and the amp and have the volume control right there on the dash.
 

·
Registered
Joined
·
483 Posts
I just tossed the one that was in my truck when I bought it - it worked but sounded as stock as it was supposed to look! bad news was either A) the installer destroyed the dash or B) the installer made his custom faceplate to cover up a previously cut up dash (the whole point of the Autosound is to keep the stock dash openings if I am not mistaken)- I installed a pioneer in a custom center console - you have to open it up with a keyed to match entry lock to even know the stereo is there - and am making a "fake" stock radio out of parts of stock stuff and a dash patch panel to try to cover the dash wounds (will just lay it over the dash for now - will correctly weld it in when I am ready to repaint).
 

·
Registered
Joined
·
162 Posts
Hello Hchinaski!

Could you provode some detail on your iPod set-up? Just curious which amp you used and how you adapted your iPod.

Thanks,
Jim
 

·
Registered
Joined
·
69 Posts
Custom Autosound

Wow, I sure got lucky (at least for now). I bought a Custom for my 55 before I read any of the problems that others are having. So far it has not given me any trouble. Don't know how long my luck will last. Usually I'm the first in line with problems about a piece of equipment.

Wish me continued luck!!
Brad :bowtieb:
 
1 - 20 of 32 Posts
Top