Chevy Tri Five Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
I found this website looking for parts for a lathe I just purchased. The company has just about every manual for every machine He will make one off parts if need be, but after I orderd some manuals from him he told me it would be cheaper getting a good machine shop locally to do the same job he could do. Honesty in a business I like that, one more thing the company is in the United Kingdom.

http://www.lathes.co.uk/index.html
 

·
Registered
Joined
·
91 Posts
Lathe Parts

Wanabe said:
I found this website looking for parts for a lathe I just purchased. The company has just about every manual for every machine He will make one off parts if need be, but after I orderd some manuals from him he told me it would be cheaper getting a good machine shop locally to do the same job he could do. Honesty in a business I like that, one more thing the company is in the United Kingdom.

http://www.lathes.co.uk/index.html
I'm a retired tool room machinist.You shouldn't have any trouble finding a shop to make your parts.Where are you located.If your from anywhere in Ca. I know you won't have a hard time finding one.What type of part are you looking for.Most parts are simple to make,unless it's something like a gear,
which is time consuming.Good luck finding a shop.
Angel,
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #4 ·
Thanks Angel

The lathe is a Delta 14'' I have no real use for it other than tinkering and have allways wanted one. I have just put a phase converter on it and it seems to be working well, I am having a bit of trouble with the rpms the upper belt jumps off at low rpms and it doesn't seem to stay in high rpms, I have to keep pulling the handle to raise them.

I live in WI, I have a line on some places to get tooling for this lathe but I don't want to spend to much until I realy need something.
 

·
Registered
Joined
·
91 Posts
Wanabe said:
Thanks Angel

The lathe is a Delta 14'' I have no real use for it other than tinkering and have allways wanted one. I have just put a phase converter on it and it seems to be working well, I am having a bit of trouble with the rpms the upper belt jumps off at low rpms and it doesn't seem to stay in high rpms, I have to keep pulling the handle to raise them.

I live in WI, I have a line on some places to get tooling for this lathe but I don't want to spend to much until I realy need something.
Sounds like you may have an alignment problem,or the belt is too loose.
 
1 - 5 of 5 Posts
Top