Chevy Tri Five Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter #1
i just got my new 5 piece front bumper for my 57 and in inspecting them I find that alot of the bolt holes do not have the chrome all the way thru the holes in fact the chrome stops short and looks about the some size as the bolt heads it is smooth so i dont think they were returns but i was wondering if i should return them or are they still ok to use?will they corrode from this area?
 

·
Registered
Joined
·
273 Posts
The ones I installed a few months ago were chromed all the way thru. I dunno about returning them but if they are the same ones as the one I got you have a bigger problem ahead of you....Making them fit your car. :D I dont want to cut anyone down so I wont mention vendors as I think one place is making these. I have done one and ordered another for soemone ...both from differnt vendors and the bumpers were from the same manufacturer. Both were good chrome but the one I installed and the one my friend installed gave fitment problems. Also, They seem much thinner than originals. JMO Tim
 

·
Registered
Joined
·
273 Posts
Sorry forgot to answer your question....I would think if it is not chromed good it will rust ...especailly where water can get trapped. Like under bolt heads. I would call and ask about it. Thats just me though. Tim
 

·
Administrator
Joined
·
48,735 Posts
I have heard of very few that said the new repro bumpers fit good. If the chrome don`t suit you now it probably won`t suit you in a few months to a year for sure. JMO
Terry
 

·
Registered
Joined
·
350 Posts
Discussion Starter #5
yeah thats what i thought well i sent them photos of all the bad spots-I will letou know who they are and how they resolve this issue-i cant even try them yet and i was all set to put them on today--now i have to mow the lawn and drink a couple beers rats thanks you guys
 
1 - 5 of 5 Posts
Top