Chevy Tri Five Forum banner
Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I'd like to pick some brains over technical issues in building my first car. I am not new to wrenching a car or truck or bike or boat. I seem to know enough to be dangerous. My dad had a full service garage in the '60s, remember FULL service? Well he had a stock car, did tuneups, sold tires, rebuilt engines & transmissions and we sold gas too. I did not carry on with that trade, I got sent to College for some book learning. I have a '68 CST pickup in storage now, it was my driver for 25 years, that will be the next resurrection. The current project is a much beloved '56 Belair. It is in pretty fair shape, it was a shed find. It is a 4 door, standard with a 6, but the 235 was swapped out in favor of a 261. I am warming that over with dual carbs, the split exhaust and Porter mufflers. The head will get shaved and I have a 3 spd. OD w/ a Hurst shifter for it. Now this is where you fit in, I will be posting here, looking for advice on the build. The car has to be on the road for spring 2011 and I have set a budget to build a reasonable driver but I like some performance and I really like handling. The car will look mostly stock but lowered and maybe loud.
 

·
Registered
Joined
·
4,141 Posts
Welcome aboard!!:sign0016:

You certainly came to the right place for questions or advice on the tri-fives.

Glad you found us:D
 

·
Premium Member
Joined
·
1,916 Posts
Welcome to bowtie-trifive Brian. Ask away, somebody will know the answer
 
Joined
·
68,758 Posts
:hello: hi brian and welcome. good to have you here and nice intro. have fun and enjoy that 56.
 

·
Registered
Joined
·
122 Posts
Hello, Brian, from another Newbie!!!

I picked up my '56 Bel Air in Baltimore yesterday and now enroute to El Dorado, AR, where I current reside. I, too, am excited about having found an experienced source of help and information. I'm heading directly to the Tech Board (if I can find it) to ask about a problem with my Powerglide failing to lock the drivetrain when placed in Park and some slight difficulty in getting it to go into Reverse.

Guys, please check me out on the Tech Board and/or tell me how to get there.

TIA,

Curley Wolf
 

·
Registered
Joined
·
19,595 Posts
WELCOME

:sign0016:To bowtie-trifive Brian from another 56 owner:shakehands: Later, Dave
 
1 - 20 of 21 Posts
Status
Not open for further replies.
Top