Chevy Tri Five Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
389 Posts
Discussion Starter · #1 ·
I recently changed the distributor on my 235. The gear was sloppy lose on the shaft and the shaft was worn. I got a nice new rebuilt one and installed it, and it works great, However, when I pulled the old one out there was no O ring or any kind of gasket on it and there was oil around the base of the distributor, not a lot but you could tell it was comming from the base of the distributor. The distributor did have a couple of groves in the body where it would fit in the block that I thought might have an O ring in one of them, but it didn't. I since have pulled several distributors from some older 235 and 216 sixes (looking for a good vacuum advance modual) and those didn't have any O ring or gaskets either. Does anyone know if there should be an O ring on the distributor? I feel there should be something on there although the oil that seeps out isn't much. Thanks in advance.
 

·
Premium Member
Joined
·
389 Posts
Discussion Starter · #4 ·
angs1957, Sorry they were not mine, I just pulled them trying to find a good vacuum advance to buy. I didn't keep them. If I run accross one again, I'll grab the grease cap for you.
 

·
Premium Member
Joined
·
389 Posts
Discussion Starter · #7 ·
Thanks D.S. and also everyone else. I feel a little better now knowing I didn't forget to install something that should be there.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top