Chevy Tri Five Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 ·
Ok guys I need your help again, I have run into another problem and this one seems to be kicking my butt. When we got the car back from my Dads cousin the power steering pulley did not line up with the rest of the pulleys. so after checking around I was told I had the wrong pulley on there. So I ordered the March 618 pulley which was what I was told was what I needed. Well that pulley will not fit the power steering pump shaft. I keep getting told I need the GM type 2 power steering pump but I have checked those out at my local parts stores and I have the same problem. Can anybody tell me something I am at my wits end trying to get this car done for my Dad with working a full time job and two little boys at home I am desperately trying to get this car done. HELP anyone please
 

·
Registered
Joined
·
37,251 Posts
Need more info on what you have now. Short/long water pump, do you have a stock accessory drive or a March drive, etc. Photos would help.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #3 ·
Rick I have a LT1 engine from a 94 Camaro but I don't know what drive system my Dads cousin put on it I have tried to find out who makes it but here is some pictures of what I have to work with.
 

Attachments

·
Registered
Joined
·
1,468 Posts
I'm not familiar with the March set up if that's what you have, but can you not shim it one way or the other. Maybe use longer bolts and spacers to get a line up?
 

·
Premium Member
Joined
·
15,901 Posts
Rick I have a LT1 engine from a 94 Camaro but I don't know what drive system my Dads cousin put on it I have tried to find out who makes it but here is some pictures of what I have to work with.
Why can't you contact your dad's cousin and ask what he put on there?
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #9 ·
Why can't you contact your dad's cousin and ask what he put on there?
because we are not on speaking terms, he had my dads car for 10 years and kept jerking us around about finishing it. So NO I can not just call and ask him becuase he doesnt take our calls and we might be seeking a law suit against him.
 

·
Premium Member
Joined
·
5,802 Posts
Looking at the pictures, the pulley is not the problem. The hose fitting I see will prevent another pulley from going back far enough. Looks like the bracket is pushing the pump too far foward. May have to redrill, or oblong the mounting holes. Being steel, your setup looks like Alan Grove components. Try contacting them.
 
1 - 10 of 10 Posts
Top