Chevy Tri Five Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello Chevy people. I have a question which I am hoping someone can help me out with. I have a 57 Chevy four door hard top, with factory power steering. It was all working fine, but she had a few leaks coming from underneath so I decided to have a mate re-kit the power steering control valve. He took out the power steering ram cylinder, (don't think he re-kited that) got new hoses made for the power steering ram cylinder. I think something else got re-kited underneath, but I can't think of the name of it. To cut a long story short, he put everything back in and put fluid in the pump. We started the car, put some more fluid in and every time you start it, the steering wheel pulls to the right full lock and you cannot turn it to the left. Where did he go wrong? Any information would be appreciated.
Thanks,
Shane
 

·
Administrator & Tech Articles
Joined
·
52,894 Posts
Shane....Contact Jalapeno.....He's the P/S expert at the site.
 
Joined
·
68,758 Posts
:hello: hi shane and welcome. good to have you here. don't know anything about ps, just wanted to wecome you. :anim_25:
 

·
Registered
Joined
·
19,595 Posts
WELCOME

:sign0016:to trifive Shane:shakehands: :anim_25:with the peoject... Later, Dave
 

·
Registered
Joined
·
12,472 Posts
Hi Shane and Welcome to TriFive :)
To me that sounds like the hoses aren't connected were they are supposed to be... or some parts not mounted correctly…
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top