Chevy Tri Five Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
i can turn on the turn signals on without the engine running they work great but when i start the engine they start hyper flashing and burn the flasher out and i have led tail lights and a electronic flasher anyone have any ideal ???? i know don answeres alot of electrical problems
 

·
Trifive Automotive Electrical Wiring Expert
Joined
·
27,084 Posts
Do you have a generator or alternator? It could be the chargeing system is putting out too much voltage. Do you notice any smell around the battery from being overcharged? Check the battery voltage while running. Should be 14 or 14.5 max.
Also, does the led flasher have a ground wire and is it grounded good?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
yes it has a alternator i have led flasher with ground wire ill check it again to make sure it has good ground it has ahorn button i honk it the other day i could smell hot wires like i said turn the key on blinkers work great start the engine they work obout 30 seconds
 

·
Trifive Automotive Electrical Wiring Expert
Joined
·
27,084 Posts
yes it has a alternator. it has a horn button i honk it the other day i could smell hot wires like i said turn the key on blinkers work great start the engine they work obout 30 seconds
Check the alternator output voltage first. Is the #2 alternator terminal connected to the alternator output terminal or to battery voltage? The alternator could be running wide open and putting out too much voltage.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
don i check there is one wire connected to abolt connection and two smaller wires in one plastic connector and i do have an amp gauge in side car the wires for the old regulater are still the and taped after i get this problem solved get my generator light to work
 
1 - 5 of 5 Posts
Top